using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://\S*?co|\b(co)\b";
string substitution = @"<a href='/co'>co</a>";
string input = @"cots and co http://me.co.uk last of my co.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}