using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+=[\w]{0})(?:&|$)";
string substitution = @"";
string input = @"http://localhost:8080/Areas/Country?AreaID=&GroupID=&PlanID=&FromDate=03/07/2016&ToDate=03/08/2016&StatusID=";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}