const regex = /(\w+=[\w]{0})(?:&|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+=[\\w]{0})(?:&|$)', 'g')
const str = `http://localhost:8080/Areas/Country?AreaID=&GroupID=&PlanID=&FromDate=03/07/2016&ToDate=03/08/2016&StatusID=`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);