import Foundation
let pattern = #"(\w+=[\w]{0})(?:&|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://localhost:8080/Areas/Country?AreaID=&GroupID=&PlanID=&FromDate=03/07/2016&ToDate=03/08/2016&StatusID="#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)