import re
regex = re.compile(r"(\w+=[\w]{0})(?:&|$)")
test_str = "http://localhost:8080/Areas/Country?AreaID=&GroupID=&PlanID=&FromDate=03/07/2016&ToDate=03/08/2016&StatusID="
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)