re = /(\w+=[\w]{0})(?:&|$)/
str = 'http://localhost:8080/Areas/Country?AreaID=&GroupID=&PlanID=&FromDate=03/07/2016&ToDate=03/08/2016&StatusID='
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result