#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-zA-Z])(?=.*[0-9])"
Local $sString = "476dn65" & @CRLF & _
"e586" & @CRLF & _
"9999" & @CRLF & _
"rrr" & @CRLF & _
"ABCF" & @CRLF & _
"01G5PFZD4ZQKKQTTB0YG22N264" & @CRLF & _
"01g5asd12312asd" & @CRLF & _
"customer" & @CRLF & _
"01G5PFZD4ZQKKQTTB0YG22N264" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")