const regex = new RegExp('^(?=.*[a-zA-Z])(?=.*[0-9])', 'mg')
const str = `476dn65
e586
9999
rrr
ABCF
01G5PFZD4ZQKKQTTB0YG22N264
01g5asd12312asd
customer
01G5PFZD4ZQKKQTTB0YG22N264
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}