using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-zA-Z])(?=.*[0-9])";
string input = @"476dn65
e586
9999
rrr
ABCF
01G5PFZD4ZQKKQTTB0YG22N264
01g5asd12312asd
customer
01G5PFZD4ZQKKQTTB0YG22N264
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}