import re
regex = re.compile(r"^(?=.*[a-zA-Z])(?=.*[0-9])", flags=re.MULTILINE)
test_str = ("476dn65\n"
"e586\n"
"9999\n"
"rrr\n"
"ABCF\n"
"01G5PFZD4ZQKKQTTB0YG22N264\n"
"01g5asd12312asd\n"
"customer\n"
"01G5PFZD4ZQKKQTTB0YG22N264\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")