re = /^(?=.*[a-zA-Z])(?=.*[0-9])/m
str = '476dn65
e586
9999
rrr
ABCF
01G5PFZD4ZQKKQTTB0YG22N264
01g5asd12312asd
customer
01G5PFZD4ZQKKQTTB0YG22N264
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end