$re = '/^ *([^\s:-][^\s:]*) *: *(.+)$/m';
$str = 'containers:
- name: api-php-container
image: us-west-2.amazonaws.com/abcd:45
ports:
- containerPort: 80
- containerPort: 443
volumeMounts:
mountPath: "/etc/keys/ssl"
- name: certs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);