re = /^ *([^\s:-][^\s:]*) *: *(.+)$/m
str = 'containers:
- name: api-php-container
image: us-west-2.amazonaws.com/abcd:45
ports:
- containerPort: 80
- containerPort: 443
volumeMounts:
mountPath: "/etc/keys/ssl"
- name: certs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end