import Foundation
let pattern = #"^ *([^\s:-][^\s:]*) *: *(.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
containers:
- name: api-php-container
image: us-west-2.amazonaws.com/abcd:45
ports:
- containerPort: 80
- containerPort: 443
volumeMounts:
mountPath: "/etc/keys/ssl"
- name: certs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)