# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=(?:[^']*'[^']*')*[^']*$)/\n/gm;t' <<< "'this is\'nt very, funny (I dont think)','is it',12345,'nope','like with 2,4,6'"