$re = '/,(?=(?:[^\']*\'[^\']*\')*[^\']*$)/m';
$str = '\'this is\\\'nt very, funny (I dont think)\',\'is it\',12345,\'nope\',\'like with 2,4,6\'';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;