const regex = /,(?=(?:[^']*'[^']*')*[^']*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?=(?:[^\']*\'[^\']*\')*[^\']*$)', 'gm')
const str = `'this is\\'nt very, funny (I dont think)','is it',12345,'nope','like with 2,4,6'`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);