using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=(?:[^']*'[^']*')*[^']*$)";
string substitution = @"\n";
string input = @"'this is\'nt very, funny (I dont think)','is it',12345,'nope','like with 2,4,6'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}