re = /,(?=(?:[^']*'[^']*')*[^']*$)/m
str = '\'this is\\\'nt very, funny (I dont think)\',\'is it\',12345,\'nope\',\'like with 2,4,6\''
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result