import Foundation
let pattern = #",(?=(?:[^']*'[^']*')*[^']*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"'this is\'nt very, funny (I dont think)','is it',12345,'nope','like with 2,4,6'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)