using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^,]*),([^,]*),([^,]*),(.*),(\d+)\s*$";
string input = @"2014-12-24 13:37:00,1.2.3.4,root,password,0
time,ip,user,,,,pass,,,,1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}