package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^,]*),([^,]*),([^,]*),(.*),(\d+)\s*$`)
var str = `2014-12-24 13:37:00,1.2.3.4,root,password,0
time,ip,user,,,,pass,,,,1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}