re = /^([^,]*),([^,]*),([^,]*),(.*),(\d+)\s*$/m
str = '2014-12-24 13:37:00,1.2.3.4,root,password,0
time,ip,user,,,,pass,,,,1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end