const regex = new RegExp('^([^,]*),([^,]*),([^,]*),(.*),(\\d+)\\s*$', 'gm')
const str = `2014-12-24 13:37:00,1.2.3.4,root,password,0
time,ip,user,,,,pass,,,,1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}