// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^,]*),([^,]*),([^,]*),(.*),(\d+)\s*$").unwrap();
let string = "2014-12-24 13:37:00,1.2.3.4,root,password,0
time,ip,user,,,,pass,,,,1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}