#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"categories\"\s*:\[(.+?)(?:,(.+?))?\]"
Local $sString = "val str = """{"data":[{"categories":["informationtech","business"],"url":"webshrinker.com"}]}"""" & @CRLF & _
"" & @CRLF & _
"val str2 = """{"data":[{"categories":["informationtech"],"url":"webshrinker.com"}]}""""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")