// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"categories\"\s*:\[(.+?)(?:,(.+?))?\]"#).unwrap();
let string = "val str = \"\"\"{\"data\":[{\"categories\":[\"informationtech\",\"business\"],\"url\":\"webshrinker.com\"}]}\"\"\"
val str2 = \"\"\"{\"data\":[{\"categories\":[\"informationtech\"],\"url\":\"webshrinker.com\"}]}\"\"\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}