re = /\"categories\"\s*:\[(.+?)(?:,(.+?))?\]/
str = 'val str = """{"data":[{"categories":["informationtech","business"],"url":"webshrinker.com"}]}"""
val str2 = """{"data":[{"categories":["informationtech"],"url":"webshrinker.com"}]}"""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end