use strict;
my $str = 'val str = """{"data":[{"categories":["informationtech","business"],"url":"webshrinker.com"}]}"""
val str2 = """{"data":[{"categories":["informationtech"],"url":"webshrinker.com"}]}"""';
my $regex = qr/\"categories\"\s*:\[(.+?)(?:,(.+?))?\]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}