$re = '/\"categories\"\s*:\[(.+?)(?:,(.+?))?\]/';
$str = 'val str = """{"data":[{"categories":["informationtech","business"],"url":"webshrinker.com"}]}"""
val str2 = """{"data":[{"categories":["informationtech"],"url":"webshrinker.com"}]}"""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);