import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"categories\\\"\\s*:\\[(.+?)(?:,(.+?))?\\]";
final String string = "val str = \"\"\"{\"data\":[{\"categories\":[\"informationtech\",\"business\"],\"url\":\"webshrinker.com\"}]}\"\"\"\n\n"
+ "val str2 = \"\"\"{\"data\":[{\"categories\":[\"informationtech\"],\"url\":\"webshrinker.com\"}]}\"\"\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}