#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+\.\d+\.\d+)(?>\-.*?\.)(\d+)"
Local $sString = "https://d1swzmic55peuz.cloudfront.net/7.0.1-5xTesi.101/" & @CRLF & _
"https://d1swzmic44peuz.cloudfront.net/7.0.0-bathrolls.103/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")