import re
regex = re.compile(r"(\d+\.\d+\.\d+)(?>\-.*?\.)(\d+)", flags=re.MULTILINE)
test_str = ("https://d1swzmic55peuz.cloudfront.net/7.0.1-5xTesi.101/\n"
"https://d1swzmic44peuz.cloudfront.net/7.0.0-bathrolls.103/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")