$re = '/(\d+\.\d+\.\d+)(?>\-.*?\.)(\d+)/m';
$str = 'https://d1swzmic55peuz.cloudfront.net/7.0.1-5xTesi.101/
https://d1swzmic44peuz.cloudfront.net/7.0.0-bathrolls.103/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);