import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\.\\d+\\.\\d+)(?>\\-.*?\\.)(\\d+)";
final String string = "https://d1swzmic55peuz.cloudfront.net/7.0.1-5xTesi.101/\n"
+ "https://d1swzmic44peuz.cloudfront.net/7.0.0-bathrolls.103/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}