# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*vndl(.dat|_\d{4}_\d{2}_\d{2}_\d{2}_\d{2}_\d{2}(_\d)*).*/\1/gm;t' <<< "logworthy/system/vndl_dat*sdgf"