const regex = /.*vndl(.dat|_\d{4}_\d{2}_\d{2}_\d{2}_\d{2}_\d{2}(_\d)*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*vndl(.dat|_\\d{4}_\\d{2}_\\d{2}_\\d{2}_\\d{2}_\\d{2}(_\\d)*).*', 'gm')
const str = `logworthy/system/vndl_dat*sdgf`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);