using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*vndl(.dat|_\d{4}_\d{2}_\d{2}_\d{2}_\d{2}_\d{2}(_\d)*).*";
string substitution = @"\1";
string input = @"logworthy/system/vndl_dat*sdgf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}