#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*vndl(.dat|_\d{4}_\d{2}_\d{2}_\d{2}_\d{2}_\d{2}(_\d)*).*"
Local $sString = "logworthy/system/vndl_dat*sdgf"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)