// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*vndl(.dat|_\d{4}_\d{2}_\d{2}_\d{2}_\d{2}_\d{2}(_\d)*).*").unwrap();
let string = "logworthy/system/vndl_dat*sdgf";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}