$re = '/.*vndl(.dat|_\d{4}_\d{2}_\d{2}_\d{2}_\d{2}_\d{2}(_\d)*).*/m';
$str = 'logworthy/system/vndl_dat*sdgf';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;