using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(parking) ([aà]\s)?(v[ée]lo) avec bornes? ";
string input = @"R1 = (local|rack|garage|emplacement|abri|parking) ([aà]\s)?(v[ée]lo)
R1_NOT = (parking) ([aà]\s)?(v[ée]lo) avec bornes?
local vélo
local à vélo
rack à vélo
garage à vélo
emplacement à vélo
abri vélo
parking vélo
[NE PAS PRENDRE EN COMPTE]
parking vélo avec borne";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}