// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(parking) ([aà]\s)?(v[ée]lo) avec bornes? ").unwrap();
let string = "R1 = (local|rack|garage|emplacement|abri|parking) ([aà]\\s)?(v[ée]lo)
R1_NOT = (parking) ([aà]\\s)?(v[ée]lo) avec bornes?
local vélo
local à vélo
rack à vélo
garage à vélo
emplacement à vélo
abri vélo
parking vélo
[NE PAS PRENDRE EN COMPTE]
parking vélo avec borne";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}