const regex = /(parking) ([aà]\s)?(v[ée]lo) avec bornes? /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(parking) ([aà]\\s)?(v[ée]lo) avec bornes? ', 'gm')
const str = `R1 = (local|rack|garage|emplacement|abri|parking) ([aà]\\s)?(v[ée]lo)
R1_NOT = (parking) ([aà]\\s)?(v[ée]lo) avec bornes?
local vélo
local à vélo
rack à vélo
garage à vélo
emplacement à vélo
abri vélo
parking vélo
[NE PAS PRENDRE EN COMPTE]
parking vélo avec borne`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}