$re = '/(parking) ([aà]\s)?(v[ée]lo) avec bornes? /m';
$str = 'R1 = (local|rack|garage|emplacement|abri|parking) ([aà]\\s)?(v[ée]lo)
R1_NOT = (parking) ([aà]\\s)?(v[ée]lo) avec bornes?
local vélo
local à vélo
rack à vélo
garage à vélo
emplacement à vélo
abri vélo
parking vélo
[NE PAS PRENDRE EN COMPTE]
parking vélo avec borne';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);