import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(parking) ([aà]\\s)?(v[ée]lo) avec bornes? ";
final String string = "R1 = (local|rack|garage|emplacement|abri|parking) ([aà]\\s)?(v[ée]lo)\n"
+ "R1_NOT = (parking) ([aà]\\s)?(v[ée]lo) avec bornes?\n\n"
+ "local vélo\n"
+ "local à vélo \n"
+ "rack à vélo\n"
+ "garage à vélo\n"
+ "emplacement à vélo\n"
+ "abri vélo \n"
+ "parking vélo \n\n"
+ "[NE PAS PRENDRE EN COMPTE]\n"
+ "parking vélo avec borne";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}