#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\/t(?:\/(\d+)\/[a-z_-]+\/?|op(\d+)\.html)$"
Local $sString = "good examples:" & @CRLF & _
"/t/2/title/" & @CRLF & _
"/t/98127/welcome_world-here/" & @CRLF & _
"/top1.html" & @CRLF & _
"/top2126.html" & @CRLF & _
"/top102542/120939.html" & @CRLF & _
"" & @CRLF & _
"bad examples: #should not match" & @CRLF & _
"/top2120/welcome/" & @CRLF & _
"/t/2121.html" & @CRLF & _
"/t/2124/bla.html" & @CRLF & _
"/blabla21051.html" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")