using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/t(?:\/(\d+)\/[a-z_-]+\/?|op(\d+)\.html)$";
string input = @"good examples:
/t/2/title/
/t/98127/welcome_world-here/
/top1.html
/top2126.html
/top102542/120939.html
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}