use strict;
my $str = 'good examples:
/t/2/title/
/t/98127/welcome_world-here/
/top1.html
/top2126.html
/top102542/120939.html
bad examples: #should not match
/top2120/welcome/
/t/2121.html
/t/2124/bla.html
/blabla21051.html
';
my $regex = qr/^\/t(?:\/(\d+)\/[a-z_-]+\/?|op(\d+)\.html)$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}