import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/t(?:\\/(\\d+)\\/[a-z_-]+\\/?|op(\\d+)\\.html)$";
final String string = "good examples:\n"
+ "/t/2/title/\n"
+ "/t/98127/welcome_world-here/\n"
+ "/top1.html\n"
+ "/top2126.html\n"
+ "/top102542/120939.html\n\n"
+ "bad examples: #should not match\n"
+ "/top2120/welcome/\n"
+ "/t/2121.html\n"
+ "/t/2124/bla.html\n"
+ "/blabla21051.html\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}